Skip to content

chore(deps-dev): update aiohttp requirement from <4,>=3.13.5 to >=3.14.5,<4 - #1612

Merged
mwbrooks merged 3 commits into
mainfrom
dependabot/pip/aiohttp-gte-3.14.5-and-lt-4
Nov 2, 2026
Merged

mwbrooks merged 3 commits into
mainfrom
dependabot/pip/aiohttp-gte-3.14.5-and-lt-4

Conversation

@dependabot

@dependabot dependabot Bot commented on behalf of github Nov 1, 2026 •

Copy link
Copy Markdown
Contributor

Updates the requirements on aiohttp to permit the latest version.

@dependabot dependabot Bot added dependencies Pull requests that update a dependency file python Pull requests that update Python code labels Nov 1, 2026
@dependabot
dependabot Bot requested a review from a team as a code owner November 1, 2026 22:13
@codecov

codecov Bot commented Nov 1, 2026 •

Copy link
Copy Markdown

Codecov Report

✅ All modified and coverable lines are covered by tests.
✅ Project coverage is 91.57%. Comparing base (b014f0d) to head (1b65954).
⚠️ Report is 1 commits behind head on main.
✅ All tests successful. No failed tests found.

Additional details and impacted files
@@           Coverage Diff           @@
##             main    #1612   +/-   ##
=======================================
  Coverage   91.57%   91.57%           
=======================================
  Files         228      228           
  Lines        7285     7285           
=======================================
  Hits         6671     6671           
  Misses        614      614           

☔ View full report in Codecov by Harness.
📢 Have feedback on the report? Share it here.

@dependabot
dependabot Bot force-pushed the dependabot/pip/aiohttp-gte-3.14.5-and-lt-4 branch 3 times, most recently from 1206ab9 to c9b93ac Compare November 2, 2026 02:54
Comment thread requirements/async_dev.txt Outdated
# Note: aiohttp 3.13.5 requires Python >=3.9; 3.7/3.8 stay on the older pinned release.
aiohttp>=3,<4; python_version < "3.9"
aiohttp>=3.13.5,<4; python_version >= "3.9"
aiohttp>=3.14.5,<4; python_version >= "3.9"

Copy link
Copy Markdown
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

issue: aiohttp 3.14.5 needs Python 3.10, so the 3.9 unit tests fail to install it. Could we keep 3.9 on the current floor and raise it only for 3.10+?

Suggested change
aiohttp>=3.14.5,<4; python_version >= "3.9"
aiohttp>=3.13.5,<4; python_version == "3.9"
aiohttp>=3.14.5,<4; python_version >= "3.10"

Copy link
Copy Markdown
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Commit 1b65954 and 1b65954 apply the above suggestion along with a comment explaining why.

---
updated-dependencies:
- dependency-name: aiohttp
  dependency-version: 3.14.5
  dependency-type: direct:development
...

Signed-off-by: dependabot[bot] <support@github.com>
@dependabot
dependabot Bot force-pushed the dependabot/pip/aiohttp-gte-3.14.5-and-lt-4 branch from c9b93ac to 5088618 Compare November 2, 2026 02:57
aiohttp 3.14.5 requires Python 3.10, so the 3.9 unit tests could not install it.
@mwbrooks
mwbrooks enabled auto-merge (squash) November 2, 2026 16:34
@mwbrooks
mwbrooks merged commit efc36b1 into main Nov 2, 2026
16 checks passed
@mwbrooks
mwbrooks deleted the dependabot/pip/aiohttp-gte-3.14.5-and-lt-4 branch November 2, 2026 16:36
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

dependencies Pull requests that update a dependency file python Pull requests that update Python code

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant