Repository navigation
fix: bump action runtime Node 20 → 22.23.4 (security hotfix) - #598
Merged
Merged
Conversation
Node 20 is EOL and will not receive the undici Brotli fix. Also aligns .nvmrc and engines with gitstream-core (>=22). Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
There was a problem hiding this comment.
Orca Security Scan Summary
| Status | Check | Issues by priority | |
|---|---|---|---|
| Infrastructure as Code | View in Orca | ||
| OSS Licenses | View in Orca | ||
| SAST | View in Orca | ||
| Secrets | View in Orca | ||
| Vulnerabilities | View in Orca |
☢️ The following Vulnerabilities (CVEs) have been detected
| PACKAGE | FILE | CVE ID | INSTALLED VERSION | FIXED VERSION | ||
|---|---|---|---|---|---|---|
| follow-redirects | ./package-lock.json | CVE-2026-111755 | 1.16.0 | 1.16.1 | View in code | |
| follow-redirects | ./package-lock.json | CVE-2026-111756 | 1.16.0 | 1.16.1 | View in code | |
| undici | ./package-lock.json | CVE-2026-109869 | 6.29.0 | 6.29.1, 7.30.1, 8.12.2 | View in code |
There was a problem hiding this comment.
🔵 Needs a closer look
The customer-facing major runtime upgrade still needs confirmation of the real-PR smoke test requested in the description.
No open issues 🎉
What changed in this PR
Updates the action’s Node.js runtime to 22.23.4 for the stated undici Brotli security fix, aligning local development and package requirements with Node.js 22.
Changes:
- Bumps the action runtime from Node.js 20.12.2 to 22.23.4.
- Aligns
.nvmrcwith the action runtime. - Raises the minimum Node.js engine requirement to 22 in both package manifests.
| File | Description |
|---|---|
package.json |
Requires Node.js 22 or later. |
package-lock.json |
Synchronizes the root engine requirement. |
action.yml |
Pins the action runtime to Node.js 22.23.4. |
.nvmrc |
Pins local development to Node.js 22.23.4. |
Review effort: Balanced
Fixes Orca findings CVE-2026-109869 (undici) and CVE-2026-111755/111756 (follow-redirects). Also pins follow-redirects in vendor-plugins so the copy vendored into dist/node_modules is upgraded too; npm otherwise keeps the already-installed 1.16.0 since it satisfies axios's range. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
There was a problem hiding this comment.
Orca Security Scan Summary
| Status | Check | Issues by priority | |
|---|---|---|---|
| Infrastructure as Code | View in Orca | ||
| OSS Licenses | View in Orca | ||
| SAST | View in Orca | ||
| Secrets | View in Orca | ||
| Vulnerabilities | View in Orca |
Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Security hotfix for the undici Brotli decompression advisory. The action ran on Node 20.12.2, which is EOL and won't receive the fix.
action.yml:setup-node20.12.2→22.23.4.nvmrc:v22.13.0→v22.23.4package.json/ lockfile rootengines:>=20→>=22(gitstream-core already requires>=22)Unit tests pass on 22.23.4. This is a major runtime bump for customers, so please smoke-test on a real PR before merging.
Dependency fixes (Orca findings)
undici6.29.0 → 6.29.1 (via@actions/http-client) — CVE-2026-109869follow-redirects1.16.0 → 1.16.2 (via gitstream-core → axios) — CVE-2026-111755, CVE-2026-111756vendor-pluginsnow pinsfollow-redirects@1.16.2: the copy vendored intodist/node_modulesfor plugins was also 1.16.0 and isn't scanned by Orca (no lockfile); without the pinnpm install --prefix distkeeps the existing version.distrebuilt withnpm run bundleon Node 22.23.4; a second rebuild is a no-op (matchesCheck dist/).🤖 Generated with Claude Code
✨ PR Description
Purpose: Upgrade the action runtime to Node 22.23.4 as a security hotfix.
Main changes:
Generated by LinearB AI and added by gitStream.
AI-generated content may contain inaccuracies. Please verify before using.
💡 Tip: You can customize your AI Description using Guidelines Learn how