Skip to content

Bump dependencies to fix security alerts - #849

Open
wu-sheng wants to merge 1 commit into
mainfrom
bump/security-deps-2026-11-02-2
Open

wu-sheng wants to merge 1 commit into
mainfrom
bump/security-deps-2026-11-02-2

Conversation

@wu-sheng

@wu-sheng wu-sheng commented Nov 2, 2026

Copy link
Copy Markdown
Member

Bump the netty that skywalking-agent.jar shades past the versions OSV flags.

Dependencies

Package Old New Manifest Advisories (OSV)
io.netty:* (netty-bom) 4.1.124.Final 4.1.139.Final pom.xml (netty.version) netty-codec: GHSA-3p8m-j85q-pgmj, GHSA-558v-64gr-wgg4, GHSA-mj4r-2hfc-f8p6; netty-codec-http: GHSA-38f8-5428-x5cv, GHSA-4mp9-239f-g9hg, GHSA-57rv-r2g8-2cj3, GHSA-6cqp-g7gg-8hr5, GHSA-6jqx-86gh-f27w, GHSA-84h7-rjj3-6jx4, GHSA-8c42-7qj2-3j46, GHSA-f6hv-jmp6-3vwv, GHSA-fghv-69vj-qj49, GHSA-gcjf-9mgh-3p7g, GHSA-hvcg-qmg6-jm4c, GHSA-jppx-w49h-x2qq, GHSA-m4cv-j2px-7723, GHSA-mvh2-crg5-v77c, GHSA-pwqr-wmgm-9rr8, GHSA-q4f6-jm68-57ww, GHSA-v8h7-rr48-vmmv, GHSA-xxqh-mfjm-7mv9; netty-codec-http2: GHSA-563q-j3cm-6jxm, GHSA-5x3r-wrvg-rp6q, GHSA-93wv-jw9v-4972, GHSA-c2gf-v879-257j, GHSA-c69g-56f8-xwqj, GHSA-f6hv-jmp6-3vwv, GHSA-w9fj-cfpg-grvv; netty-handler: GHSA-3qp7-7mw8-wx86, GHSA-c4c3-7fpv-j4q5, GHSA-c653-97m9-rcg9, GHSA-fccg-mwvh-qqg4, GHSA-x4gw-5cx5-pgmh; netty-handler-proxy: GHSA-45q3-82m4-75jr
io.netty:netty-tcnative-boringssl-static 2.0.70.Final 2.0.84.Final pom.xml the version netty 4.1.139.Final is built with

OSV reports none of these advisories for 4.1.139.Final. Dependabot raises no alert for them because the version comes from the netty-bom import. gRPC stays on 1.74.0.

dist-material/LICENSE names netty 4.1.139. CHANGES.md updated.

Dependabot alerts

The 249 open alerts are all on apm-sniffer/apm-sdk-plugin/** and apm-application-toolkit/** poms: provided-scope framework targets, test scope, or micrometer-core GHSA-g3pr-3p32-fp23, which has no fixed version. None are touched here.

GitHub Actions

No change: every uses: already matches the ASF allowlist (#846).

infra-e2e

Not used by this repository.

Verified locally

  • ./mvnw clean package -Dmaven.test.skip=true -pl apm-sniffer/apm-agent -am on JDK 17 (git-commit-id skipped in a git worktree): pass. The shaded skywalking-agent.jar carries netty 4.1.139.Final and netty-tcnative 2.0.84.Final, with the relocated tcnative native libraries for linux x86_64/aarch_64, osx and windows.
  • ./mvnw test -pl apm-protocol/apm-network,apm-sniffer/apm-agent-core: 97 tests, 0 failures.
  • Not run: the plugin tests and E2E (CI runs them), a JDK 8 build (the enforcer requires JDK 17+ to build).

Left out on purpose

  • guava 32.1.3-jre (apm-agent-core, shaded) carries GHSA-xxph-c9ww-hj94, fixed in 33.7.2. The root pom says not to upgrade Guava until Java 8 is EOL, so it stays. For the record: guava 33.7.2-jre classes are Java 8 bytecode (class file 52) with a root module-info.class.

Shipped in skywalking-agent.jar (shaded):
- netty 4.1.124.Final -> 4.1.139.Final (root pom netty.version, through
  netty-bom). OSV lists 4.1.124.Final for netty-codec (GHSA-3p8m-j85q-pgmj,
  GHSA-558v-64gr-wgg4, GHSA-mj4r-2hfc-f8p6), netty-codec-http (18
  advisories, e.g. GHSA-4mp9-239f-g9hg, GHSA-8c42-7qj2-3j46), netty-codec-http2
  (7, e.g. GHSA-93wv-jw9v-4972), netty-handler (5, e.g. GHSA-c4c3-7fpv-j4q5)
  and netty-handler-proxy (GHSA-45q3-82m4-75jr); 4.1.139.Final has none.
- netty-tcnative-boringssl-static 2.0.70.Final -> 2.0.84.Final, the
  version netty 4.1.139.Final is built with.
- dist-material/LICENSE names netty 4.1.139. CHANGES.md updated.

guava stays on 32.1.3-jre (see the pom comment on Java 8).
@wu-sheng wu-sheng added this to the 9.9.0 milestone Nov 2, 2026
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant